Back to overview
Downtime
Contact Center – Service Restored
Apr 07 at 02:50am EDT
Affected services
Contact Center
Resolved
Apr 07 at 03:30am EDT
🚨 Contact Center – Service Restored
📅 Incident Report:
Date: Monday, April 7, 2025
Time: Started at 2:50 AM (ET) – Resolved by 3:30 AM (ET)
The issue affecting the Contact Center services earlier this morning has been resolved. All services are now fully operational.
Affected services
Contact Center
Created
Apr 07 at 02:50am EDT
🚨 Contact Center – Service Outage Alert
📅 Incident Report:
Date: Monday, April 7, 2025
Time: Started at 2:50 AM (ET)
We are currently experiencing an issue with the Contact Center services.
Affected services
Contact Center